Ga naar inhoud
Log in om dit te volgen  
Gast

Kleine Vragen Topic #4

Aanbevolen berichten

Sjoerd (link):
Stef (link):
Bij stap 8 van de installation guide van de OpenCart updater staat het volgende:
Quote:
STEP 8. FIND: // DIR

Kan iemand mij vertellen wat ze daarmee bedoelen?


Je moet [c]// DIR[/c] vinden in de config.php die je die stap daarvoor geopend hebt?


Ohw smiley
Ik dacht dat ik een bepaalde file moest zoeken ofzo smiley
Bedankt smiley

Deel dit bericht


Link naar bericht
Delen op andere sites
Ik wil een shoutcast status controleren of die online/offline is. Ik weet dat dit met fsockopen() kan, maar dit duurt wel lang voor de loadtime. Is hier een makkelijkere optie voor?

Deel dit bericht


Link naar bericht
Delen op andere sites
Ik heb een € teken in een tabel staan, wanneer ik dit op wil halen krijg ik een vraagteken met een zwart rondje. Heb een doctype met utf-8. Wat doe ik verkeerd?


toevoeging op 26 februari 2015, 14:03:55:
Aarclay (link):
Geen makkelijkere optie, wel een vriendelijkere.....

Laad het met AJAX in, dan wordt de pagina synchroon geladen smiley


Thanx, ga ik proberen! smiley

Deel dit bericht


Link naar bericht
Delen op andere sites
Gast
Marvinguich (link):
Ik heb een € teken in een tabel staan, wanneer ik dit op wil halen krijg ik een vraagteken met een zwart rondje. Heb een doctype met utf-8. Wat doe ik verkeerd?


toevoeging op 26 februari 2015, 14:03:55:
Aarclay (link):
Geen makkelijkere optie, wel een vriendelijkere.....

Laad het met AJAX in, dan wordt de pagina synchroon geladen smiley


Thanx, ga ik proberen! smiley


Je moet € gebruiken smiley

Deel dit bericht


Link naar bericht
Delen op andere sites
Aarclay (link):
Volgens mij moet € ook gewoon werken, als je de juiste encoding overal goed hebt ingesteld.
Dat sowieso, als jij hier € typt dan wordt dat ook niet als € opgeslagen in de database.

Deel dit bericht


Link naar bericht
Delen op andere sites
Gast
Ik heb jullie mening even nodig!

Codeblok:
1
2
3
import std;

std.Writeln(Hoi);


Codeblok:
1
2
3
import std.Writeln;

Writeln(Hoi);


Codeblok:
1
2
3
import std = lol;

lol.Writeln(Hoi);


Codeblok:
1
2
3
import std.Writeln = lolol;

lolol(Hoi);


Codeblok:
1
2
3
4
import std.*;

Writeln(Hoi);
Write(Doei);


Is dit correcte behavior volgens jullie?

Deel dit bericht


Link naar bericht
Delen op andere sites
Gast
Voornamelijk om de syntax simpel te houden en niet teveel token types te hebben.

Deel dit bericht


Link naar bericht
Delen op andere sites
Marvinguich (link):
Goede doctype ingesteld, en nog krijg ik een vraagteken met een zwart rondje.

Doctype staat er los van. het gaat om de encoding.
Stel deze in via de meta-tags, en via PHP-headers. Zorg ook dat de bestanden de juiste encoding hebben evenals de database.

Deel dit bericht


Link naar bericht
Delen op andere sites
Waarom zeggen sommige mensen dat bijvoorbeeld een <BR> afgesloten moet worden: <br />?

Deel dit bericht


Link naar bericht
Delen op andere sites
Gast
[c]<br />[/c] is verouderde XHTML syntax, met HTML5 mag je tegenwoordig gewoon je tags afsluiten zonder [c]/[/c].

En opgelet: HTML tags schrijf je zonder hoofdletters. Tenzij je in de jaren 90 programmeert smiley

Deel dit bericht


Link naar bericht
Delen op andere sites
Raoul (link):
[c]<br />[/c] is verouderde XHTML syntax, met HTML5 mag je tegenwoordig gewoon je tags afsluiten zonder [c]/[/c].

En opgelet: HTML tags schrijf je zonder hoofdletters. Tenzij je in de jaren 90 programmeert smiley


Nee, autocorrectie op telefoon smiley

Deel dit bericht


Link naar bericht
Delen op andere sites
Ik heb een OpenCart template waar ik in beide het volgende gebruik:
Codeblok (voorbeeld.php):
1
2
3
[<?php if ($description) { ?>
<meta name="description" content="<?php echo $description; ?>" />
<?php } ?>

Maar wanneer ik nummer 2 gebruik krijg ik foutmeldingen als
Quote:
Notice: Undefined index: description in /home/website/domains/website.be/public_html/update/catalog/view/theme/websitetheme/template/common/footer.tpl on line 9

En bij de andere theme krijg ik deze meldingen niet terwijl ik daar ook $description gebruik.
Ze zijn allebei aangesloten op dezelfde database en zouden toch gewoon hetzelfde moeten doen?

Het OpenCart forum wil mijn reactie niet goedkeuren, ik denk dat dat forum is uitgestorven ofzo smiley
Weet iemand hier de oplossing?

Deel dit bericht


Link naar bericht
Delen op andere sites
Stef (link):
Ik heb een OpenCart template waar ik in beide het volgende gebruik:
Codeblok (voorbeeld.php):
1
2
3
[<?php if ($description) { ?>
<meta name="description" content="<?php echo $description; ?>" />
<?php } ?>

Maar wanneer ik nummer 2 gebruik krijg ik foutmeldingen als
Quote:
Notice: Undefined index: description in /home/website/domains/website.be/public_html/update/catalog/view/theme/websitetheme/template/common/footer.tpl on line 9

En bij de andere theme krijg ik deze meldingen niet terwijl ik daar ook $description gebruik.
Ze zijn allebei aangesloten op dezelfde database en zouden toch gewoon hetzelfde moeten doen?

Het OpenCart forum wil mijn reactie niet goedkeuren, ik denk dat dat forum is uitgestorven ofzo smiley
Weet iemand hier de oplossing?


Probeer eens het volgende op regel 1: [c]<?php if(isset($description) && $description != "") { ?>[/c]

Deel dit bericht


Link naar bericht
Delen op andere sites
Bugged (link):
Stef (link):
Ik heb een OpenCart template waar ik in beide het volgende gebruik:
Codeblok (voorbeeld.php):
1
2
3
[<?php if ($description) { ?>
<meta name="description" content="<?php echo $description; ?>" />
<?php } ?>

Maar wanneer ik nummer 2 gebruik krijg ik foutmeldingen als
Quote:
Notice: Undefined index: description in /home/website/domains/website.be/public_html/update/catalog/view/theme/websitetheme/template/common/footer.tpl on line 9

En bij de andere theme krijg ik deze meldingen niet terwijl ik daar ook $description gebruik.
Ze zijn allebei aangesloten op dezelfde database en zouden toch gewoon hetzelfde moeten doen?

Het OpenCart forum wil mijn reactie niet goedkeuren, ik denk dat dat forum is uitgestorven ofzo smiley
Weet iemand hier de oplossing?


Probeer eens het volgende op regel 1: [c]<?php if(isset($description) && $description != "") { ?>[/c]


Nogsteeds dezelfde foutmeldingen smiley
Quote:
Notice: Undefined index: description in /home/website/domains/website.be/public_html/update/catalog/view/theme/websitetheme/template/common/footer.tpl on line 9

Maar het is niet alleen die foutmelding he, ook deze bijvoorbeeld:

Quote:
Notice: Undefined variable: stores in /home/website/domains/website.be/public_html/update/catalog/view/theme/websitetheme/template/common/header.tpl on line 42Notice: Undefined variable: google_analytics in /home/barbecue/domains/website.be/public_html/update/catalog/view/theme/websitetheme/template/common/header.tpl on line 51

Deel dit bericht


Link naar bericht
Delen op andere sites
Stef (link):
Bugged (link):
Stef (link):
Ik heb een OpenCart template waar ik in beide het volgende gebruik:
Codeblok (voorbeeld.php):
1
2
3
[<?php if ($description) { ?>
<meta name="description" content="<?php echo $description; ?>" />
<?php } ?>

Maar wanneer ik nummer 2 gebruik krijg ik foutmeldingen als
Klik om eerdere quotes te tonen

En bij de andere theme krijg ik deze meldingen niet terwijl ik daar ook $description gebruik.
Ze zijn allebei aangesloten op dezelfde database en zouden toch gewoon hetzelfde moeten doen?

Het OpenCart forum wil mijn reactie niet goedkeuren, ik denk dat dat forum is uitgestorven ofzo smiley
Weet iemand hier de oplossing?


Probeer eens het volgende op regel 1: [c]<?php if(isset($description) && $description != "") { ?>[/c]


Nogsteeds dezelfde foutmeldingen smiley
Quote:
Notice: Undefined index: description in /home/website/domains/website.be/public_html/update/catalog/view/theme/websitetheme/template/common/footer.tpl on line 9

Maar het is niet alleen die foutmelding he, ook deze bijvoorbeeld:

Quote:
Notice: Undefined variable: stores in /home/website/domains/website.be/public_html/update/catalog/view/theme/websitetheme/template/common/header.tpl on line 42Notice: Undefined variable: google_analytics in /home/barbecue/domains/website.be/public_html/update/catalog/view/theme/websitetheme/template/common/header.tpl on line 51


Is dit weer niet zon query-fout wat je eerder ook had?

Deel dit bericht


Link naar bericht
Delen op andere sites
Bugged (link):
Stef (link):
Bugged (link):
Klik om eerdere quotes te tonen


Probeer eens het volgende op regel 1: [c]<?php if(isset($description) && $description != "") { ?>[/c]


Nogsteeds dezelfde foutmeldingen smiley
Quote:
Notice: Undefined index: description in /home/website/domains/website.be/public_html/update/catalog/view/theme/websitetheme/template/common/footer.tpl on line 9

Maar het is niet alleen die foutmelding he, ook deze bijvoorbeeld:

Quote:
Notice: Undefined variable: stores in /home/website/domains/website.be/public_html/update/catalog/view/theme/websitetheme/template/common/header.tpl on line 42Notice: Undefined variable: google_analytics in /home/barbecue/domains/website.be/public_html/update/catalog/view/theme/websitetheme/template/common/header.tpl on line 51


Is dit weer niet zon query-fout wat je eerder ook had?


Nee want in de template worden geen querys uitgevoerd. Alleen kan de andere template wel de variables gebruiken en de mijne niet. Ze staan op precies dezelfde site en aangesloten op dezelfde database smiley

Deel dit bericht


Link naar bericht
Delen op andere sites
Stef (link):
Bugged (link):
Stef (link):
Ik heb een OpenCart template waar ik in beide het volgende gebruik:
Codeblok (voorbeeld.php):
1
2
3
[<?php if ($description) { ?>
<meta name="description" content="<?php echo $description; ?>" />
<?php } ?>

Maar wanneer ik nummer 2 gebruik krijg ik foutmeldingen als
Klik om eerdere quotes te tonen

En bij de andere theme krijg ik deze meldingen niet terwijl ik daar ook $description gebruik.
Ze zijn allebei aangesloten op dezelfde database en zouden toch gewoon hetzelfde moeten doen?

Het OpenCart forum wil mijn reactie niet goedkeuren, ik denk dat dat forum is uitgestorven ofzo smiley
Weet iemand hier de oplossing?


Probeer eens het volgende op regel 1: [c]<?php if(isset($description) && $description != "") { ?>[/c]


Nogsteeds dezelfde foutmeldingen smiley
Quote:
Notice: Undefined index: description in /home/website/domains/website.be/public_html/update/catalog/view/theme/websitetheme/template/common/footer.tpl on line 9

Maar het is niet alleen die foutmelding he, ook deze bijvoorbeeld:

Quote:
Notice: Undefined variable: stores in /home/website/domains/website.be/public_html/update/catalog/view/theme/websitetheme/template/common/header.tpl on line 42Notice: Undefined variable: google_analytics in /home/barbecue/domains/website.be/public_html/update/catalog/view/theme/websitetheme/template/common/header.tpl on line 51


Gebruik eens alleen [c]if(isset($description))[/c]

Deel dit bericht


Link naar bericht
Delen op andere sites
Dylan (link):
Stef (link):
Bugged (link):
Klik om eerdere quotes te tonen


Probeer eens het volgende op regel 1: [c]<?php if(isset($description) && $description != "") { ?>[/c]


Nogsteeds dezelfde foutmeldingen smiley
Quote:
Notice: Undefined index: description in /home/website/domains/website.be/public_html/update/catalog/view/theme/websitetheme/template/common/footer.tpl on line 9

Maar het is niet alleen die foutmelding he, ook deze bijvoorbeeld:

Quote:
Notice: Undefined variable: stores in /home/website/domains/website.be/public_html/update/catalog/view/theme/websitetheme/template/common/header.tpl on line 42Notice: Undefined variable: google_analytics in /home/barbecue/domains/website.be/public_html/update/catalog/view/theme/websitetheme/template/common/header.tpl on line 51


Gebruik eens alleen [c]if(isset($description))[/c]


Ja, ik begrijp dat ik dan geen errors krijg, maar de $description output gewoon een of andere tekst, die alleen werkt in de oude template maar wanneer ik dezelfde variables gebruik in een nieuwe template krijg ik niks.

Deel dit bericht


Link naar bericht
Delen op andere sites
Wouterr (link):
@Stef, zet je niet ergens $description in die andere template? (e.g. header o.i.d.)


Oh verrek ik denk dat ik er achter ben wat er mis is smiley
De error bedoelt niet de variable description maar $output[description] die in de footer staat (denk ik) smiley

Deel dit bericht


Link naar bericht
Delen op andere sites
Raar probleem, ik heb een forwarder aangemaakt in directadmin naar een Gmail email-adres. Nu stuur ik daar een mail heen, en staat in mijn exim mainlog:

gmail-smtp-in.l.google.com [] Network is unreachable

Mail komt ook niet aan. Hoe kan dit?

Deel dit bericht


Link naar bericht
Delen op andere sites

Maak een account aan of log in om te reageren

Je moet lid zijn om een reactie te kunnen achterlaten

Account aanmaken

Maak een account aan in onze gemeenschap. Het is makkelijk!

Registreer een nieuw account

Aanmelden

Ben je al lid? Meld je hier aan.

Nu aanmelden
Log in om dit te volgen  

×